Menu

Bullet Graph

In this tutorial, you’ll learn how to draw a Bullet Graph in Glimpse to visualize performance metric data.

Open the Data Grid from the bottom of the window and add the data from the table below:

Measure Measure Value Rating Rating Range Target
Revenue 320 Bad 200 340
Revenue 320 Good 100 340
Revenue 320 Great 100 340


Next, go to the Inspector panel > Visual > Mark and set the Mark Type to Bar.

image1


Now, from the left side under Fields, drag the Rating Range field into the X encoding and switch off the Title toggle in the Inspector panel. The Inspector panel is to the right side of the window.

image2


Next, drag the Measure field into the Y encoding and deactivate Title in the Inspector panel.

image3


Then, drag the field Rating into the Color encoding. You should now see different colors of the rating range to the right side of the graph for Bad, Good, and Great.

image4


You can now change each color. Go to the Inspector panel and open the Visual section. Then, in the Encoding tab open the Scale dropdown and > Range, press the + button 3 times, one time for each color. A color picker will pop up for each color. That’s where you can change each shade. Enter 3 shades of grey (or any other color) of decreasing darkness.

image5


To adjust the height of the chart, go to the Visual section of the Inspector, click on the Layer tab. Then, under the Layout dropdown set the Height to 100 pt.

image6


You will now create a new layer for the Measure feature. From the top menu, choose Insert > Layer > Bar.

image7


Then, drag the field Measure Value into the X encoding and Measure into the Y encoding.

image8


To adjust the appearance of the Measure feature, go to Visual > Mark > Size in the Inspector panel and enter 30 pt in the Height field under Size.

image9


After, change the Color to black.

image10


To add the ‘comparative measure’, from the top menu go Insert > Layer > Tick.

image11


Drag the field Target into the X encoding.

image12


To make the comparative measure larger, go to the Visual section of the Inspector panel. Then, go to Mark > Size and set the Size to 7 pt.

image13


To make the comparative measure more visible, set the Color to black and under Stroke set the Thickness to 4 pt.

image14


Done! This concludes this tutorial on drawing a Bullet Graph. If you want to further customize your chart, please read the documentation.